Needed adobe flash 10+ support.
Download Flash here.